Cisco Router Configuration Example

The following example contains marking and Class-Based Weighted Fair Queuing (CBWFQ) with Low Latency Queuing (LLQ) for VoIP. SIP traffic is not treated. The example assumes a LAN Ethernet interface and a WAN Serial T1 interface. Quality of service is configured to guarantee the following:

  • Strict priority for four G.729 VoIP calls marked as EF.
  • Reserved bandwidth for two 'task worker' PCoIP sessions marked as AF41 (500 kbps minimum peak bandwidth, limited ability for over-subscription).
  • The default class gets all the remaining bandwidth and is fair queued.

Sample Cisco router configuration settings:

!match PCoIP packets
access-list 100 permit tcp any any eq 4172
access-list 100 permit udp any any eq 4172
``bash class-map match-all VOIP-IN match ip rtp 16384 16383 class-map match-all PCOIP-IN match access-group 100
```bash
class-map match-all VOIP-OUT
match ip dscp EF
class-map match-all PCOIP-OUT
match ip dscp AF41
policy-map ETH-IN
class VOIP-IN
set ip dscp EF
class PCOIP-IN
set ip dscp AF41
policy-map SERIAL-OUT
class VOIP-OUT priority 128
class PCOIP-OUT
bandwidth 1000
class class-default
fair-queue
interface Serial 0/1
bandwidth 1544
no fair-queue
service-policy output SERIAL-OUT
!trust dscp markings coming into this router from across the WAN
!do this if you need Layer 2 COS QoS and have a DSCP-COS map defined or set COS on e0/1
mls qos trust dscp
interface Ethernet 0/1
service-policy input ETH-IN